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1. Group work - Multi-sheet 

2. Selections and moves. 

 Non-continuous selection 

 Click on a selection tab, hold the CTRL button down and add the desired sheets with a click 
on the tab per sheet. 

 Continuous selection 

 Click on the tab of the first sheet of the selection, hold the key (Shift/Maj.) pressed down 
and then click on the last sheet of the selection. 

 Select all the sheets 

 Click with the right button on a sheet tab, then click Select all sheets in the pop-up menu. 

 

THE TABS IN THE SELECTION WILL APPEAR IN WHITE .  THE MESSAGE  [GROUP]  

WILL APPEAR IN THE TITLE BAR .  TO DISABLE A WORKING GROUP ,  CLICK ON A 

TAB THAT DOES NOT BELONG TO THE WORKING GROUP .   IF ALL THE TABS ARE 

PART OF IT ,  CLICK ON ONE OF THEM ,  EXCEPT THE FIRST ONE . 

 Select multiple sheets (create a group) 

Creating a group will allow changes to be applied to multiple sheets of the same workbook at the same time. 

The way of doing things will be somewhat different depending on whether the sheets are in continuous 

selection or not. 

 Change the color of a tab 

From the pop-up menu obtained by clicking with the right button on the tab of the sheet to be 
changed, select the Tab Color option. 
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 Moving from one sheet to another in a workbook 

 If the tab or "the sheet" you are looking for is visible on the 
tab row, just click on it.   

 If the workbook contains several sheets, not all tabs may be 
visible, you can click on one of the scroll buttons to the left 
of the tabs. 

 

 Or right click this scroll buttons, the box will display all existing 
sheets in this workbook, select the desired sheet. 

 

 Move a sheet or copy a spreadsheet 

It is possible to copy or move sheets in the same workbook or to another workbook. 

You can also copy a full spreadsheet from one workbook or another workbook. This way of working is the 
most effective because the spreadsheet will respect the layout, i.e. the headers and foot of the page. 

1. To do so, from the Home tab, click on the Format icon  Move Or copy sheet. Or right click 

on the sheet. 

 

2. In the To book area, click on the destination workbook. 

3. To move or copy selected sheets in a new workbook, click (new book). 

4. In the Before Sheet area, click on the sheet in front of which you want to insert the moved (or 

copied) sheet.  

5. To copy the sheets instead of moving them, activate the checkbox Create a copy. 
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To move sheets inside the current workbook, you can drag the selected sheets onto 
the row of sheet tabs. To copy sheets, hold the CTRL button down and drag them; 
Release the mouse button before releasing the CTRL button. 

To copy sheets, hold the CTRL button down and slide; release the mouse button before 
releasing the CTRL button. 

 

3. Copy - paste with link 

You can link multiple sheets or workbooks with copying - Paste with link, how to do it? 

 EXERCISE 1: Paste with link 

You want to copy sub-totals from a spreadsheet to a new sheet, however, you 
want the values to be linked i.e. that the changes are made simultaneously, 
How to do it?   

1. Open the file "Paste Link sheet "Compilation". 

2. Copy cells B14 to E14 from Sheet  Montreal  

3. Select cell B5 from sheet  Compilation. 

4. From the Home Tab  Group Clipboard Other Paste 
Options  choose  Paste link 

 

5. Repeat the steps to insert the totals from sheet "St-Bruno" into 
sheet Compilation.  

6. Here is the result. Do not save and close. 
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Now let's copy the same data, but in another way to better understand the absolute 
reference. 

 EXERCISE 2 Paste with link, absolute reference 

1. Open file "Paste Link", sheet "Montreal". 

2. Activate cell B14 and click "Copy". 

3. Select cell B5 from sheet  Compilation.  

4. From the Home Tab  Group Clipboard   Paste Options  choose Paste link 

 

5. Confirm 

6. Here is the answer: 

Name of the sheet 

 

Absolute reference 

$ sign in front of B Means: always column B. 

$ sign in front of 14 Means: always row 14. 

So always cell B14 of the Montreal sheet 

7. Change the value of cell E5 of the Montreal sheet, which is 330, to 1100, note that your 
result has been changed on the sheet "Compilation". 

8. Save and close. 

4. Get a sum of several sheets. 

You want to get the sum of the totals of each sheet of a workbook, for example: compiling sales of 12 
months, How to Do it? 

1. Open the file « Summary », sheet « Summary » 

2. Activate cell B4. 
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3. Click the  Automatic Sum button  on the Home tab or the Formulas tab. 

4. Select sheet "January", click in cell B4 which represents the sum of piano sales for the month 
of "January". 

5. Hold the SHIFT key down and click on sheet "December" to select the January to December 
sheets from the workbook. 

6. Validate with the Enter button. 

7. The answer in cell B4 is 104,980  =SUM(jan:dec!B4) 

8. Copy the formula from B4 to B9 

9. Repeat the same operation in B12 and copy the formula in B 13 and B14 

   

5. Formatting - Multi-sheet 

You can format all your sheets (tabs) of a workbook in a single operation.  

Select all the sheets and from the "Page Layout" tab, make all the changes: Orientation, header, and 
footer, etc. 

You cannot do this by going through the preview before printing. 

Do not forget to leave the working group after this operation. 
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6. View multiple sheets on the screen. 

Often, we would like to view more than one sheet on the screen, how to do it? 

1. Make sure you have only one open workbook. 

2. From the View tab, click "New Window". 

3. Now click Arrange All, Choose "Vertical"   

    

4. If you want a third sheet, repeat step 2 and 3. 

ADDITIONAL CONCEPTS 

This exercise is a supplement to working with multiple sheets or workbooks. We could call it 

"COMBINE," but EXCEL uses the term "CONSOLIDATE" 

7. Consolidation 

So far, you have worked and grouped data using multiple sheets. Now you're going to work with multiple 
workbooks while incorporating links between workbooks. 

Excel offers the command "Consolidate" which allows you to make summaries, Example: "Sum", 
"Average" and others...from the Consolidate function. There are 2 types of consolidation, by Position 
and by Category 

 Consolidation by Category 

Unlike the Position Consolidate method, there is no need to respect the structure of the sheets or 
workbooks you want to consolidate. Notice that the 3 workbooks have the same products, but they 
are not positioned in the same places. 

 EXERCISE - Consolidation by category 

1. Open the following files: "Cat Laval", "Cat Montreal", "Cat Dorval " and  
"Cat Chocolate_TT". 
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2. Activate cell A4 of the target workbook, i.e. "Cat Chocolate TT". 

3. Open the dialog box  Consolidate  Data Tab  Select the "Sum" function in the drop-
down list  Function. 

4. Click the button  Reference. 

5. Activate the Cat Montreal workbook from  View Tab  Switch Windows  

6. Select data: A4 to F13 

7. Click add. 

8. Click the Reference button again. 

9. Repeat steps 5 to 9 to enter data A4 to F13 data from file Cat Dorval and Cat Laval in 
the dialog box  Consolidate. 

     

 

10. Check the left column box. 

11. Check the Create links to source data box. 
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12. Click OK 

13. Expand column A 

14. Click in the + located to the cell  Coconut (Row 24), click in the cell representing Dorval, 

Laval, and Montreal. Observe the answer in the formula bar. 

15. Save and close. 

RESULT OF THE EXERCISE  

 

8. Using a function 

FUNCTIONS  SUM  :  HOW TO USE THEM? 

Functions are programmed computational operations. They allow complex calculations to be made. All 
functions are identified by keywords. 

To insert a function, press  button called "Automatic Sum or Sigma Icon". This 
option gives you access to the more commonly used functions: automatic sum, average, 
minimum, maximum, counter. 

The option "More functions" will open the dialog "Insert function ".  
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 New method with new versions 

From THE FORMULAS TAB 

In the Function Library Group, click into the desired function, the Function Arguments window will 
appear. 

  

 Formula Assistant 

THIS EXERCISE AIMS TO HELP YOU WITH THE USE OF FUNCTIONS AND ASSISTANT FUNCTIONS  

1. Type in the text below: 

 

2. Activate cell B6 to get the average of "exam 1 ". 

3. Type "=«, type "AVERAGE", type parenthesis "(" + the cells containing the results of "Exam 

1" =AVERAGE(B2:B4), the result is "71" 

4. If you want to get the "Maximum" rating, you will type "MAX" or for the "Minimum" rating, 

you will type "MIN". 

 Definition of some basic functions. 

FUNCTIONS EXPLANATION 

SUM 
 

MAX 
 

MIN 
 

AVERAGE 

 

COUNT 
 

COUNTA 
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9. RELATIVE OR ABSOLUTE ADDRESSES 

 Relative address: 

 Whose formula adjusts during a copy. 

 Absolute address: 

 Fixed address, it does not change during a copy. 

 Mixed address: 

 Relative column and absolute line: B$2. Row 2 stays fixed, while the column adjusts when 
copying. In our case below, by copying the formula to the right, Excel calculates the timelines 
of each row from the deadlines located only in row 2 for each column. 

 Absolute column and relative row: $A3. Column A remains fixed while the row adjusts when 
copying. In our case below, by copying the formula down, Excel calculates the timelines of 
each row from the dates located only in column A. 

 F4 key, to get absolute reference 

 The cell chosen to perform the formula remains the same. Excel returns to the same column 
and row when copying. 

EXAMPLE OF RELATIVE  ADDRESSES: 
 

A B C D 

1 Quantity Description Price Total 

2 20 Cell 200 =A2*C2 

3 25 DVD 275 =A3*C3 

4 15 Radio 95 =A4*C4 

EXAMPLE OF ABSOLUTE  ADDRESSES: 
 

A B C D 

1 Description Price GST QST 

2 
  

5% 9,975% 

3 Cell 200 =B3*$C$2 =B3*$D$2 

4 DVD 275 =B4*$C$2 =B4*$D$2 

5 Radio 95 =B5*$C$2 =B5*$D$2 
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EXAMPLE OF MIXED  ADDRESSES: 

 A B C D E 

1  Billing date DEADLINE 1 DEADLINE 2 DEADLINE 3 DEADLINE 4 

2    30 60 90 360 

3  2023-08-15 =$A3+B$2 =$A3+C$2 =$A3+D$2 =$A3+E$2 

4  2023-07-24 =$A4+B$2 =$A4+C$2 =$A4+D$2 =$A4+E$2 

5  2023-07-29 =$A5+B$2 =$A5+C$2 =$A5+D$2 =$A5+E$2 

10. INSERT DATE 

 Option 1: STATIC DATE, Date that will not be updated 

 Activate the destination cell to insert the date of the day. 

 Press the "CTRL" button, then the "semicolon key" ";" 

 Today's date appears.  "CTRL + " 

 Option 2: Date to be updated 

Insert a date that will be updated for future use of the 
workbook. How do I do that? 

Activate the destination cell, type: The sign = and type 
TODAY,  
add an opening and closing parenthesis ( ). Confirm with 
Enter 
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11. Sorting data 

Unlike filtering, which momentarily hides lines containing unselected data, the sorting function reorganizes 
data from the selected range according to the "Smallest to largest or Largest to smallest" selection criteria. 

HOW DO I  DO THAT? 

1. Open the "Calculation intermediate" file, "Subtotal" sheet.  

2. Activate a single cell of the column that you want to get sorted. 

3. From the Home tab, click  Sort and filter from the Editing group then on to sort in 

ascending order, or on to sort in descending order. 

4. You can also sort from the Data tab 

 

 Sort by multiple columns 

 Open the "Calculation intermediate" file, "Subtotal" sheet. 

 Activate a cell in the table. 

 In the Home tab, click on  Sort and Filter from the Editing Group  

 Choose "Custom Sort " 

 Sort by  Choose  Example: Last name. 

 In the Sort dialog box, click  Add Level  then by "First Name". 

 Add a third level:  Then by "#No." 

 Click OK 
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 Sort by color 

 Open the "Calculation intermediate" file, "Employee" sheet. 

 Activate a cell 

 On the Home tab, click Sort and Filter  

 Choose "Custom Sort..." from  "Group Editing " 

 Sort by  choose  First Name 

 In the "Sort On" box, choose  Font Color 

 

 Box "Order "  Choose a color  

 Tab "Copy Level" three times 

 Check the result, the colors are grouped together, but are not in alphabetical order 

 Go back to the dialog box again and add a level 

 Keep the color "Automatic" last 

 This must be last and "Then by" to be able to sort with each color 

 Click OK and see your result 

 

 Sort using a custom list 

 If necessary, open the " Calculation intermediate " file  sheet "Employee"  

 On the Home tab, click Sort & Filter from the  Group Editing 

 Choose "Custom sort..." » 
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 Sort by  choose  Holidays (Months) 

 In the "Sort to" box, choose  Cell Value 

 In "Order", choose "Custom List" 

 

 Then choose the right date format: day or month (whole or diminutive) 

 It is from this dialog box that you can add other lists according to your needs, example: a 
list in French. 

 This option is also found in "File" "Options" "Advanced" "Edit Custom Lists" 

 

Note: 

 ___________________________________________________________________________________  

 ___________________________________________________________________________________  

 ___________________________________________________________________________________  

 ___________________________________________________________________________________  

 ___________________________________________________________________________________   
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12. Filtering data in a range or table 

Data filtering is a quick and easy way to search for and manipulate a subset of data from a cell range or 
table. For example, you can filter to show only the values you specify, to view the higher or lower values, or 
to quickly display duplicate values. 

Once you've filtered data in a cell range or in a table, you can either reapply a filter for up-to-date results, or 
erase a filter to review all the data. 

To use filtering without delay, select at least one cell in a range or excel table, then click the Filter button 
(Data tab, Sort & Filter group). 

 

Filtered data only shows rows that meet the specified criteria and hides those you don't want to see. Once 
the data is filtered, you can copy, edit, format, graph and print without reorganizing or moving it. 

You can also filter the data in multiple columns. Filters are additive, i.e. each additional filter is based on the 
active filter, further reducing the subset of data displayed. 

 The three types of filters 

 Text 

 Number 

 Date 

 To undo a filter or reapply the filter 

 A drop-down filtering list indicates that filtering is enabled, but not applied. 

 A Filter button indicates that a filter is being applied. If you want to undo the filter, the option 
Clear Filter is in the drop-down menu. 

 Data has been added, deleted, or modified in the cell range or table column. 

 Reapplying the filter means that it will filter again with our last command. 
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 Filter text 

Selecting values from a list and searching are the fastest filtering methods. When you click the arrow in a 
column that is filtered, all the values in that column appear in a list. The following illustration shows three 
methods of rapid data filtering. 

 

 Use the Search area to enter text or numbers to search for. 

 Select and deselect checkboxes to see the values in the data column. 

 Use the advanced criteria to find values that meet specific criteria. 

 Select a range containing alphanumeric data. 

 Under the Data tab, in the Sort & Filter group, click Filter. 

 Click on the arrow in the column header. 

 In this list, click or unclick the checkbox of one or more text values to filter. 

 Criterion: Custom filter. 

 In the area on the right of the Custom Automatic Filter dialog box, type text or select the 
appropriate text value from the list. 

 To filter the table column or selection so that both criteria are checked, select And.  

 To filter the la table column or selection so that one or both criteria are checked, select Or. 

 To filter numbers 

1. Take one of the following actions: 

2. Select a range containing digital data. 

3. Under the Data tab, in the Sort & Filter group, click Filter. 

 Make sure the active cell is in a table column containing digital data. 

 Click on the arrow in the column header. 
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 In this list, select or deselect the numbers to be checked. 

 The list can contain up to 10,000 numbers. If it contains a lot of numbers, turn off the 
checkbox (Select All) at the top and select the numbers on which the filter should be applied. 

 To filter the data by above-average numbers, click Above average or Below Average. 

 Criterion: Custom filter. (Numbers) 

FOR EXAMPLE ,  TO FILTER THE NUMBERS ACCORDING TO UPPER AND LOWER LIMITS ,  CLICK 

BETWEEN.  

 In the area or areas displayed on the right of the Custom Automatic Filter dialog box, type 
numbers or select them from the list.  
for example, to filter the numbers between 25 and 50. 

 

 You can also add one or more filtering criteria. 
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 Filter dates or times 

1. Take one of the following actions: 

2. Under the Data tab, in the Sort & Filter group, click Filter. 

3. Make sure the active cell is in a table column with dates or 

times.  

4. Click on the arrow in the column header. 

5. Point to Date Filters and do one of the following: 

 Click on one of the comparison operators (Equals, Before, 
After or Between) or on Custom Filter. 

 In the area on the right of the Custom Automatic Filter dialog 
box, enter a date or time, select a date or time from the list, or 
click the Calendar button to search for a date and enter it. 

 For example, to filter all dates according to the date of the day, 
select Today or to filter based on the following month, select 
Next Month. 

 The menu All dates of the Period, such as January or 
Quarter2, filter by period, regardless of the year. This type of 
filtering can be useful, especially when comparing sales by 
period over several years. 

 This Year and Year to date orders differ in the way future dates 
are processed. This Year returns future dates for the current 
year, while Year to Date only returns dates up to and including 
the current date. 
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 Delete all filters 

1. To view all the data, click Clear from the Data tab. 

2. Or if you want to erase the Montreal filter only and keep the other 

filters (other columns), In the column city, press  Clear the filter 

"Department." 

3. To remove all filtering arrows,  click  on FILTER from the Data tab 

 

 

 Advanced filter 

Sometimes, you cannot do what you need with regular filter. We will have to use a  Advanced Filter. 

Also use  Advanced Filter to create a list of unique items, or to extract specific items to a different 
worksheet.  

1. Open "Calculation Intermediate" file, "Sub-total' sheet 

 

2. Once the criteria area is created, (See above) you can start the filter. 

3. Make sure the list is continuous and contains unique column labels. 

4. Place the cell pointer anywhere in the list. 

5. Choose the Data tab  Sort & FILTER  SELECT "ADVANCED" The 

following dialog box appears: 

6. Make sure the "List range" area covers the full extent of the list you want to analyze. 

7. Enter the address of your search criteria in 
the "Criteria range" area. 

8. See your result including Laval and 
Lavaltrie 
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 See the exception Rule - Advanced Filter 

 Empty field, non-empty field in advanced filter 

To filter out fields with empty content, type in the criterion area:  

To filter out non-empty content: type  

 Other exceptions 

The following criteria allow you to find Laval employees, working in finance with a salary of less 
than 40,000 and in maintenance earning more than 40,000. 

   

If we don't pay attention to Laval, we'll also get "Lavaltrie". 

To filter out  Laval only content: type  

Also if you want all cities, but "not Laval" « <> »  

 Copy to another sheet. 

Normally, you choose the COMMAND DATA, SORT & FILTER, ADVANCED when the sheet containing the list to 
be analyzed is active. Excel then allows you to copy to another location in the same sheet records that meet 
the stated criteria. You can “bypass” Excel with the following procedure if you want the search result to 
appear on a different sheet. 

1. Place the cell pointer on the sheet where you want the search 
result to be displayed. 

2. Choose the COMMAND DATA, SORT & FILTER, ADVANCED  

3. Choose “Copy to another location.” 

4. Select your data  List range. 

5. Select  Criteria range. 

6. Copy to  Click in your cell, click the  button to validate your order. 
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13. Removing duplicates 

If there are rows with identical data, Excel can find and delete them. 

1. Positioning yourself in the table 

2. In the Data tab, use "Remove duplicates". 

 

3. Select fields to be verified and click OK. 

 

4. A message will indicate the number of duplicates found and their removal. 
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14. Data validation 

Data validation controls the type of data and values enter in a cell. For example, you may want to restrict 
data entry to a certain range of dates, limit the choices available by using a list, or make sure that only whole 
numbers have entered. 

This article describes how data validation works in Excel and presents the different techniques available. It 
does not address cell protection, that is, the feature that allows you to "lock" or hide certain cells in a 
spreadsheet to prevent data from being changed or replaced. 

 What is validation? 

Data validation is an Excel feature that sets restrictions on the type and values of data allowed in a cell. You 
can set up data validation to prevent users from entering data that is not valid. If you prefer, you can allow 
users to enter invalid data but notify them when they type it into cells. You also can display messages 
detailing the type of input expected for cells, as well as instructions to help users correct errors. 

If users ignore this message and type invalid data into the cell, such as a two or five digit number, you can 
display an error message. 

 

DATA VALIDATION COMMANDS ARE LOCATED UNDER THE DATA TAB IN THE 

DATA TOOLS GROUP .  

DO NOT FORGET TO RESPECT THE CASE -  UPPERCASE OR LOWERCASE  

 When to use data validation? 

Data validation is particularly useful when sharing a workbook with others in your 
organization, for which you want the data entered to be accurate and consistent. 

You can use data validation to perform, among other things, the following tasks: 

 Limit data with a list 
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HERE'S AN EXAMPLE TO LIMIT THE LIST AMONG A SELECTED ONE SUCH AS : 

 Limit with little data 

1. Open Calculation Intermediate workbook, Sheet  Employee 

2. Select Column E  Department, then go to the Data Validation box. 

3. Select  List  in Validation criteria  Allow 

4. In SOURCE, type:  Don’t forget the  Coma or Semicolon between data 
Finance,Maintenance,Marketink,Sale. 

 

5. Click OK 

6. Watch the drop-down menu in the cell 
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 Other method to limit with a list 

EXAMPLE:  TO CREATE A LIST IN SHEET "PAYMENT",  COLUMN "G"  

1. In a new sheet  in Calculation Intermediate workbook, insert the column Payment 
method into A1. 

2. Type the text below 

 

3. Choose sheet "Payment" to create your validation in column "G". 

4. Select your data G2 to G12 

5. Go to the Data Validation box. 

6. Choose List  in Validation criteria  Allow. 

7. In "Source," click on the reference  and select the data from the new sheet 

 

8. In "Source," click on the reference and select the data from  New sheet. 

9. See your result and save. 
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 Limit numbers outside of a specified range 

In a particular cell, you can specify a minimum or maximum limit. 

 

 Limit the number of text characters 

You can limit the authorized text in a cell to 10 characters or less. Similarly, you can set the specific length 
of the number or text so that it corresponds to the length, example: Maximum of 4 characters. 
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 Data validation messages 

What users see when they enter invalid data into a cell 
depends on how you set up data validation. You can 
choose to display an input message when the user 
selects the cell. Input messages are generally used to 
offer users advice on the type of data that can be 
entered into the cell. You can move this message if you 
wish. It then remains displayed until you move to 
another cell or press Esc. 

 

 

 View an error message for invalid data. 

    

 There are 3 types of error message: 

Icon Type Use to 

 

Stop 
Prevent users from entering invalid data into a cell. A Stop Alert offers 
two options: Retry or Cancel. 

 

Warning 

Warns users that the data entered is not valid, without preventing them 
from entering it. When a Warning message appears, users can click 
Yes to accept the invalid entry, no to change the invalid entry, or 
Cancel to delete the invalid entry. 

 

Information 

Informs users that the data entered is not valid, without preventing 
them from entering it. This type of error message is the most flexible. 
When an Information message appears, users can click OK to accept 
the value or Cancel to opt out. 
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 Steps to create a drop-down list 

WE WILL CREATE A LIST WITH THE CITIES ,  HOW TO DO IT? 

We will use the Workbook Calculation Intermediate  sheet "Employee " 

Step 1. Select the cities in "Column D " 

Step 2. Copy your data "CTRL + C " 

Step 3. Create a new sheet and rename it "Validation" 

Step 4. Paste values into the new sheet 

Step 5. Remove duplicates (Function also located in "Data Tools" 

Step 6. Go back to the "Employee" sheet and reselect the column if necessary 

Step 7. You are ready to insert the drop-down list, so click on "Validation" 

Step 8. Choose  "List" 

Step 9. Click in the "Reference" and select the cities that are in the "Validation" sheet  

Step 10. If you have selected the entire column, do not forget to remove this validation in the title  
"D1 "  "City" 

Step 11. Also, if the list is very large, it would be wise to sort your data 

15. Conditional formatting 

Conditional formatting can be used to visually 

annotate data for presentation or analysis 

purposes. To easily detect exceptions and identify 

important data trends, several conditional 

formatting rules can be applied and managed that 

apply to visual formatting in the form of color 

gradients, data bars and icons.  

 Color Scales 

 Icon sets 

 Search for duplicates, etc. 

 

By applying conditional formatting to your data, you can quickly identify deviations within a range of values. 

Place the mouse pointer above the color scale icons to get an overview of the data with conditional 
formatting. 
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This chart shows temperature data with a conditional formatting that uses a color scale to differentiate high, 
medium, and low values. The following procedure uses this data. 

 How to create a conditional formatting – Color scales 

Select the data you want to apply conditional formatting to 

 

Apply conditional formatting. 

Under the Home tab, in the Styles group, click the arrow next to Conditional Formatting, then on Color 
Scales. 

Place the mouse pointer above the color scale icons to 
get an overview of the data with conditional formatting. 
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 Example  :  

 Open "Calculation Intermediate " sheet "Payment” 

 Select "Total Sales" Column "F"  

 In "Conditional Formatting"  choose  Top/Bottom Rules  then  Above 
Average… 

 

 Choose a color 

  

 Return In "Conditional Formatting"  choose  Top/Bottom Rules  then  Below 
Average… 

 Choose a different color. 

 Click "OK" 

 Conditional formatting – Quick analysis 

Select the data you want to apply conditional formatting to apply conditional formatting. 

If you click  Quick analysis   you will get this 

box to help you with Conditional formatting 

Under the Home tab, in the Styles group, click the 
arrow next to Conditional Formatting, then on 
Color Scales. 
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 Icon sets 

1. Open the "Chart " sheet of the Calculation Intermediate workbook and select all exam 
notes. 

2. Apply conditional formatting Icon sets/Indicators (Circled) to your selection. 

 

3. Manage the rules in order to get color "green " all notes above or equal to 70, in 
yellow the notes between 70 and 60 and in red the notes below 60.  

4. Verify if you want "Type " in "Percentage" or "Number". 

5. You also able to "Reverse Icon Order "  

6. And decide to "Show Icon Only " 

7. And change the style of the Icon at the bottom  

 
8. See the result 
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 Simple Conditional formatting 

1. Open the Employee sheet of the Calculation Intermediate workbook and select column D. 

2. Under the Home tab, in the Styles group, click the arrow next to Conditional Formatting,  
then on Equal to. 

   

3. Type Laval 

4. Click OK 

 Conditional Formatting with Simple Formula 

 Open "Excel_In_Classe"  "Registration" sheet  

 SELECT ALL DATA (Not the sheet)  

 Click on "Manage Rules" Then "New Rule" 

 Choose "Use a formula to determine which cells to format " 
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 In "Format values where this formula is true:  
Type  =$E1= "Winter" 

 This means "search for Winter in column "E" and apply formatting to all selected cells ". 

 Increase the "APPLIES TO"  

 

 You can click on "Duplicate rule" and change the color and season to avoid retyping 

the formula. 

 Conditional formatting with positive and negative values 

 Open "Excel_In_Classe ", "MEFC" sheet 

 If necessary, insert the formula in "B3" to get the amount in loss or savings per month on 
the food budget  

 

 Select the data and choose "New Rule" Choose "Data Bar" in "Formatting Style" 
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 Change the color if necessary. 

 See your result, nice and look like a chart design. 

16. Find - Replace 

The Find and Replace dialog box offers several options to modify text in a workbook. The main objectives 
of the search are to correct errors, to modify a word, to change a formula in a sheet or workbook. 

1. Open the Calculation Intermediate file, "Employee" sheet. 

2. Observe the error in the word "St-Bruno". To correct all the words in the sheet, 

HOW DO YOU DO THAT? 

1. From the Home tab, click   Find  from the Editing group  

 

2. Type "St-Bruno," select the "Replace" tab, type "Saint-Bruno,"  

3. Choose "Replace All" in the dialog box. 

   

 

By clicking Options in the "Find and Replace" dialog box, more options become available 
and allow to change the word with a new Font, Border or Fill 

4. To change the word "finance" to get in Bold and Blue, in "Replace with"   click in "Format" 

and in the Font tab, choose Bold and Blue 

5. If you don't want to change all the words "Finance," click "Find Next" to switch to the next 

word "Finance," click "Replace" to change, otherwise move on to the next one until the search 

is complete. You can also click "Replace All". 

6. Click "Replace All" to replace all the words "Finance" in bold and blue"  
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 Search for part of a word or for a sentence: 
 

GENERIC CHARACTER ,  FUNCTION AND EXAMPLE  

? 
Replaces a single character: 
Ex. ?o  Search  « go » « to » « do » 

* 
Replaces one or more characters at the indicated position: 

Ex.  c*r  « car » « cancer » replaced by « cutter » 

* Replaces all characters placed before or after the entry value 

 Why use "Search" instead of "Filter" 

 

SOMETIMES IT IS FASTER TO USE THE "SEARCH"  FUNCTION RATHER THAN THE 

FILTER.   

SEARCH FOR A CODE ,  A PRODUCT NUMBER IN A DATABASE WITH A LOT OF LINES ,  

YOU TYPE THE VALUE AND CLICK ON "NEXT" 

17. Format as table 

All these changes are interesting but require a lot of time (and sometimes imagination), so why not let Excel 
do some work for us. 

1. Select the cell or cell range in the table to which you want to apply a table format. 

2. In the Home tab, click Format as Table.  

3. Click on the desired table style. 

4. Select a cell in your data. 

5. Select Home, Styles Group, Format as Table. 

6. Choose a style for your table. 

 

7. In the Format as Table dialog Box, set the cell range. 

8. Check this option if your chart has headers. Select OK. 
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You can also adjust the layout of the table by choosing the Table Style Options for elements of the table, 
such as Header Row, Total Row, First Column, Last Column, Banded Rows and Banded Columns or 
Filter Button. 

When you use the Format as Table option, Excel automatically converts your data range into a table. If you 
no longer want to manipulate your data in a table, you can Convert to Range, while keeping the format. 
You'll find this option in the "Table Design " tab. 

 

 Be careful to convert to range 

Once you've converted your table to a range and made a change (Example: Sorting on another 
column), formulas already inserted in the table will no longer be sorted. 

We're going to have to start all your formulas over again. 

 Here is a solution to fix the problem: 

 Removing the background color  

 Replacing the sheet name with the Find & Replace command  
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18. Subtotal 

IMPORTANT MESSAGE  

The Subtotal command appears grayed out if you are using a Microsoft Excel table. To add subtotals to a 
table, you must first convert the table to a range. 

Subtotals are calculated with a synthesis function, such as Sum or Average, using the SUBTOTAL 
function. You can view several types of synthesis functions for each column. 

If the workbook is set up to automatically calculate the formulas, the Subtotal command automatically 
recalculates the subtotal and total values as soon as you change the data. The Subtotal command also 
displays a data synthesis function, details "in outline mode" to allow you to view or hide the row details of 
each sub-total. 

 Insert subtotals 

1. Type in the text below 

   

2. Select a single cell in the Department column. 

3. To sort the column that contains the data to be grouped, you must sort the data. 

4. In the group Sort & Filter, click Sort A to Z or Sort Z to A. 

5. Under the Data tab, in the Outline group, click Subtotal. 

 

6. The Subtotal dialog box /appears. 
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7. In the area  At each change in, click on the column for which you want to calculate the 
subtotal. In the example above, you need to select Department. 

8. In the Use function area, click on the synthesis function you want to use to calculate subtotals. In the 

example above, you need to select Sum.  

9. In the Add subtotal to, activate the checkbox of each 
column containing the values for which you want to 
calculate the subtotal. In the example above, you 
need to select Weekly income. 

10. To set an automatic page break after each sub-total, 
activate the checkbox Page break between 
groups. 

11. To specify a summary line above the row of details, 
deactivate the checkbox Summary below data. To 
specify a summary line below the detail list, activate 
the checkbox Summary below data. In the 
example above, you need to deactivate the 
checkbox. 

12. You have the possibility, as an option, to reuse the 
Subtotal command several times, up to seven 
consecutive times, to add other subtotals with 
different synthesis functions. To prevent the existing 
subtotals from being crushed, deactivate the 
checkbox Replace current subtotals. 

13. Click Ok and here is your result:   

14. To see subtotals only, 

click on the number 2 at the top left. 

 

 Use more than one function in subtotals 

Example: to obtain the number of people per department while keeping the sum of salaries per 
department. 

1. Click Subtotal 

2. In the area  At each change in, we keep Department. 

3. In the area Use function, choose Count. 
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4. Deactivate the checkbox Replace current subtotals. 

 

 Delete subtotals 

 Select a cell in the range that contains subtotals. 

 Under the Data tab, in the Outline group, click Subtotal. 

 In the Subtotal Dialog box, click Remove All. 

19. Custom Views 

When you work on a spreadsheet, you want to view this sheet in different ways. For example, the sheet 
includes several columns with sub-totals, and you need to view or print sub-totals only. How do I do that? 

 How to Create a Custom View 

1. First thing to do is your  Page Layout and  Header & footer 

2. From  View tab  Custom Views 

    

3. Click the button  Add. 

4. Enter the name you want to give to the display in the text box. 

5. In  Include in view, make sure you have the checkmark in the following 2 options:   Print 
settings and Hidden rows, columns, and filter settings. 

6. Click OK 
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 EXERCISE: Custom views 

1. Open the file "Calculation Intermediate" 
 sheet "Montreal AP". 

2. Select cell A1. 

3. From the View tab, then "Custom Views" 

 click Add. 

4. Type "complete" 

5. Make sure you have the 2 boxes checked 
in the window. 

6. Click OK 

7. Hide columns "B C D F G H J L N O P". 

8. Prepare your "Page Layout", change "Header & Footer", the size of your Paper 

9. From the View tab, then "Custom Views" 

 click Add  Type "Total". 

10. Click OK 

11. To get the "complete" view you've 
created, from the  Custom Views menu 
bar  choose the "complete" view of the 
dialog box or to get totals view only, 
choose "Total". 

12. This option will allow you to view or print 
totals and sub-totals in the future without having to hide columns. 

 What is very importance to understand? 

 

IN A YEAR OR MORE ,  YOU WILL HAVE MORE DATA . 

YOU DO NOT HAVE TO ALWAYS HIDE ROW AND COLUMN.  

HEADER AND FOOTER FOLLOW ,  DATA ALSO  

Note: 

 ___________________________________________________________________________________  

 ___________________________________________________________________________________  

 ___________________________________________________________________________________  

 ___________________________________________________________________________________  

 ___________________________________________________________________________________  
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20. Convert Data "Text to Columns " 

This function allows us to separate the text of a cell into several columns. Or for example, to convert a date 
that is in TEXT format into a DATE format. 

 

 Convert text 

1. Open Calculation Intermediate workbook  

sheet Text to column 

2. Select A1 to A5 

3. From the Data tab 

4. Click in Text to columns   

5. Choose Delimited in Step 1 of 3  

 

6. Go to Step 2 out of 3. 

7. Choose the comma. 

8. View the result in the Data 
preview. 

9. Click Finish 
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 Separate data with nothing in between 

1. Open " Calculation Intermediate "  " Text to Columns " sheet 

2. Select from A14 to A22 

3. From "Data tab "  "Data tools " choose  "Text to Columns " 

4. Step 1  choose  "Fixed width"  "Next " 

 

5. Step 2  Click where is necessary to separate the two first letters from the numbers  
 Next  

 

6. Step 3  First column is "General ", this is correct 
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7. Click in the second column 

8. We must choose  "Text ", because we do not want to lose the "ZEROS" 

   

 Convert a date, but in TEXT format 

1. Type a date like this: (DD-MM-YYYY), 25-12-2020. 

2. Notice that EXCEL does not recognize this date. 

3. Click Text to Columns  

4. Immediately move to Step 3 of 3 

5. Choose: DATE 

6. Choose from the drop-down list the date format we typed: DMY. 

7. Click Finish 
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21. Charts 

A chart is a visual element that facilitates the understanding of numerical or statistical data. It quickly 
illustrates trends, compares data with each other, and highlights the relationships between elements.  

A chart has many elements. Some of them are displayed by default, others can be added as needed. You 
can change the view of elements in a chart by moving them to other locations in the chart, resizing them, or 
changing the layout. You can also remove chart items you do not want to see.  

 Creating a chart 

A chart is generated from the data on a spreadsheet.  
Open workbook "Calculation intermediate", sheet "Clinical"  

 

The selection of data is very important. Generally, the first column and row of a data range are used to 
describe the "X" axis (abscissa) and the legend. Excel interprets it very well when the first column and the 
first row of the block are text. Empty rows or columns should not be included. If a non-continuous 
range is to be used, make sure that each range represents at least one set of data. 

To avoid having too large scales, it is best not to take columns and rows with totals.  

The easiest way to produce a chart after selecting the data is to press the F11 button. The result (below) 
will appear in a new window. 
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 Know the elements of a chart 

A chart has many elements. Some of these items appear by default, while others can be added as needed. 
You can change the view of the graphic elements by moving them inside the chart, resize them, or change 
their layout. You can also remove graphic items you don't want to see. 

1. Chart area (chart area: whole chart and constituent elements.) of the chart. 

2. Plot area (plot area: in a 2D chart, area bounded by axes, and which includes all data sets. In a 3D 
chart, an area defined by the axes, which includes all data sets, category names, graduation labels and 
axis titles.) of the chart. 

3. Data points (data points: individual values plotted in a chart and represented by bars, columns, lines, 
sectors, rings, points, and various other forms called data markers. Data markers of the same color 
constitute a data series.) data series (data series: linked data points, plotted in a chart. Each of the data 
series in a chart has a unique color or pattern and is represented in a graphic legend. You can plot one 
or more series of data in a chart. The pie charts have only one series of data.) traced in the chart. 

4. Axes (axis: line bordering the plot area of the chart and serving as a reference for measurement. The 
ordinate axis (Y) is generally vertical and contains data. The abscissa axis (X) is usually the horizontal 
axis and contains categories.) horizontal (abscissa) and vertical (ordinate) along which the data is traced 
in the chart. 

5. Legend (legend: area identifying patterns or colors assigned to data series or categories in a chart.) of 
the chart. 

6. Title (titles in charts: descriptive text automatically aligned to an axis or centered at the top of a chart.) 
of the chart and axis that can be used in the chart. 

7. Data label (data label: a label that provides additional information about a data marker representing a 
data point or value from a spreadsheet cell.)  to identify the details of a data point in a data series. 

 Changing a basic chart to suit needs 

Once you've created a chart, you can edit any of its elements. For example, you can change the way axes 
are displayed, add a title, view, or hide the caption, or show more graphics. 

TO EDIT A CHART,  YOU CAN DO ONE OR MORE OF THE FOLLOWING : 

 Change the axes display of the chart. You can specify the scale of the axes and adjust the interval 
between the values or categories displayed. To make your chart more readable, you can also add tick 
marks (tick marks and tick labels: tick marks are small measurement lines that look like the divisions of 
a ruler and are located on an axis. Tick mark labels identify abscissa, ordinate, or chart series.) to an 
axis and specify the interval at which they should appear. 

 Add titles and data tags to a chart To clarify the information presented in your chart, you can add a 
title, axis titles and data tags. 

 Add a legend or a data table. You can view or hide a legend, move it, or change its elements. In some 
charts, you can also view a data table that displays legend symbols (legend symbols: symbols in 
legends that show patterns and colors assigned to a chart's data series (or categories). Legend symbols 
appear on the left of the legend elements. The layout assigned to a legend symbol is also applied to 
the data mark associated with it.) and the values presented in the chart. 
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 Sparkline 

1. Open file: Calculation Intermediate, sheet « Sparkline »   

2. Select cell  K2. 

3. From the Insert Tab - Sparkline - choose "Line"  

 

4. Location Range: select from B2 to J12 and click OK. 

 

5. Copy from cell K2 to K8 

6. See your result 

 

 Other options - Chart 

The purpose of this exercise is to demonstrate how to create a chart integrated into an Excel spreadsheet.   

1. To generate your chart, you need to select data. Excel accepts continuous or discontinuous 

selections for charts. The first row and column may contain text. 

2. Open file: "Calculation Intermediate", Select cells "A2 to E8" of the GRAPHIC sheet.  
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3. Click on  Column  of the Insert Tab   

 

4. Choose the first option of the chart: 2-D column 

Here's the result. 

 

5. Click in Switch Row/Column, from the Design tab to change the look of the chart based 

on the data. 

 

See the result ans the difference in your chart (Next page) 
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6. To change the type of chart 

 

7. To change the format of the chart, make sure to drop the cursor in the chart, then from 

the Creation tab, Chart Styles, choose a style:   
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22. Cell protection 

By default, all cells in a sheet are locked. You will find this option  

in  Format Cells  Group Cells  Protection Tab 

 

It is important to protect cells to avoid mistakenly removing sometimes complex formulas. This is done in 

two steps.  First, you must unlock every cell you want to access, only the cells that have been unlocked 

will be accessible. The second step is to protect the sheet with or without a password. You can do this step 

in  Review tab  Protect Sheet. 

 Sheet protection 

HOW TO PROTECT THE SHEET  

1. From  Review tab Protect Sheet. 

2. Activate options you do not want to protect. 

3. Enter a password (you can leave this area empty) 

4. Click OK 

5. Protection can also be found in the «Format icon" of the "Cells" group. 

6. Also Right click with your moose on a sheet 
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 To remove the protection 

If you want to change the contents of a locked cell or hidden formulas, you should disable the protection of 
the sheet. Select  Unprotect Sheet Review tab. 

    
 

DON'T FORGET TO PROTECT THE 

SHEET AGAIN IF YOU MAKE 

CHANGES .  

 Protect Workbook 

WHY SHOULD WE PROTECT WORKBOOK? 

 

THIS OPTION IS IN "REVIEW TAB "  GROUP "PROTECT "  

 

WE  WILL  PROTECT  THE  STRUCTURE  TO  PREVENT  SHEETS  

FROM  MOVING  DUE  TO  THE  FORMULAS 

ALSO,  TO  PREVENT  HIDING  OR  UNHIDING  SHEETS. 
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23. Exercise 1 – Paste with link. 

Open workbook "School statistics link", in the "Multi-sheet" folder 

1. Insert the average into the 3 sheets for groups A-B and C 

2. Compile the result of groups A B and C in the "Summary" sheet, using "Paste link" 

3. Hide the "Summary" sheet 

24. Exercise 2 - Paste with link. 

Open the "Chocolate" workbook in the "Multi-Sheet" folder 

1. Insert the sum into the 4 sheets for quarters 1 - 2 - 3 - 4   

In a single operation. 

 Compile the data with link in the "Annual summary" sheet 

2. Compile quarterly results in the "Annual summary" sheet, using "Paste link" 

3. Format all sheets 

 Format: Landscape 

 Align horizontally and vertically. 

 File name on the left, date in the center, sheet name on the right 

 Change the titles of row 2 to read: Sale for the year 202X instead of: 

Place Versailles 

 Tab color on the sheet created on all sheets. 

 Protect the "Annual summary sheet in writing 

25. Review - Formulas 

Open the "Exercise" workbook 

1. Insert formulas in sheets "Employees" and "Supermarket". 

2. Sheet "Deadline" 

 Insert today date in Cell "A9". 

 Insert the formulas from B3 to E9 
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26. Exercise 1 - Sub-totals 

Open the "Exercise" workbook 

1. Sheet: "Employees"   

 We want to see the sum of salaries per department. 

 And the number of employees per department 

27. Exercise 2 - Sub-totals 

Open the "Exercise" workbook 

1. Sheet: "Supermarket"   

 We want to see the sum of sales per Farm. 

 And the sum of sales per product 

2. Sheet: "Boutique"   

 Sum of sales per year 

 And the sum of sales per season 

28. Exercise - Conditional formatting 

Open the "Exercise" workbook 

1. Sheet: "Employees"   

 Conditional formatting If the person lives in: Montreal 

(Please do not use the same color) if the salary is more than 1 000 

2. Sheet: "Boutique"   

 Conditional formatting if the category is: Girl 

 Column F (Sales), choose: Color scales 

29. Exercise – Custom sort 

Open the "Exercise" workbook 

1. Sheet: "Employees", column: First name 

 Sort by font color "Blue - Green - Red - Automatic" 

 Make sure each color is also in alphabetical order 
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30. Exercise - Custom Views 

Open the "Exercise" workbook 

1. Sheet: "RV"   

 Layout: Landscape 

 Make sure the sheet is adjusted to a page in width. 

 Footer to be created (Your choice) 

 Create a custom view, name it: Complete 

2. Create a new custom view to get a list of patients who will undergo surgery next month. 

 Hide a few columns. 

 This sheet must be in "Portrait" mode. 

 Header: List of surgical patients for next month 

 Create a custom view, name it: Surgery 

3. Create a new custom view to get the doctor's patient list: Lori Price 

 Hide the columns: B - E and H 

 Header: List of patients in "Gynecology" for next week 

 Create a custom view, name it: Lori Price 

31. Exercise - Validation 

Open the "Exercise" workbook 

1. Sheet: "RV"   

 Column: Sex 

 Message: Enter F for Female or M for Men 

2. Sheet: "Employees"   

 Limit value to 4 digits 

 Title: Message from Management 

 Message: Enter a 4-digit number 

3. Sheet: "Boutique"   

 Season: Spring - Summer - Autumn - Winter  

 Category: Girl - Women - Boy - men 
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32. Exercise - Advanced Filter 

Open the "Exercise" workbook 

1. Filters to be applied in the "Boutique" sheet. 

 Filter the women list for the Spring season 

 And the men list for the Fall season 

2. Repeat the same exercise by copying your data into a new sheet 

3. Rename the sheet: "Advanced Filter"   

33. Exercise - Chart 

Open the "Summary" workbook in the "Multi Sheets" folder 

2. Sheet: "Jan"   

 Select cells from A3 to B9 

 Create a "3D Section" chart (Pie) 

 Insert a Title to your chart. 

 Insert percentage value. 

 Make changes and explore 

 


